Fresh Licode Installation not working according to the install guide

Hi there,

I am trying to install the Licode on a fresh Ubunto 14 server by following the guide located at http://lynckia.com/licode/install.html
unfortunately I have encountered several areas where I got stuck which needs to be mentioned in the document for easy process, first I had to install the openssl and then doxygen was required, further it is now using NVM so that had to be installed too. Once these items were installed I was able to move further, however now I get stuck at the following when running installErizo script:
I would appreciate if someone can assist… I am unable to perform the Make and getting the message:
No rule to make target `//licode/erizo/build/all’. Stop.

Following is the output when installing erizo:

root@ubuntu:/# ./licode/scripts/installErizo.sh
Installing erizo…
– Found Doxygen: /usr/bin/doxygen (found version “1.8.6”)
– Found glib-2.0: /usr/include/glib-2.0, /usr/lib/x86_64-linux-gnu/libglib-2.0.so;/usr/lib/x86_64-linux-gnu/libgobject-2.0.so;/usr/lib/x86_64-linux-gnu/libgthread-2.0.so
– Boost version: 1.54.0
– Found the following Boost libraries:
– thread
– regex
– system
– Found glib-2.0: /usr/include/glib-2.0, /usr/lib/x86_64-linux-gnu/libglib-2.0.so;/usr/lib/x86_64-linux-gnu/libgobject-2.0.so;/usr/lib/x86_64-linux-gnu/libgthread-2.0.so
– Boost version: 1.54.0
– Found the following Boost libraries:
– thread
– regex
– system
– Configuring done
– Generating done
– Build files have been written to: //licode/erizo/build
Done
make[1]: *** No rule to make target `//licode/erizo/build/all’. Stop.
make: *** [all] Error 2

root@ubuntu:/licode/erizo/build# ls
CMakeCache.txt cmake_install.cmake Doxyfile libdeps test
CMakeFiles CTestTestfile.cmake erizo Makefile third_party
root@ubuntu:/licode/erizo/build#

I appreciate a feedback

AB

The Licode documentation is not up to date. With the current codebase installation goes fine if you download the repository and use the commands
cd licode
./scripts/installUbuntuDeps.sh

If I remember right, you have to run the installation of Erizo and Nuve from the licode directory also.

Thanks for the info, I will try and feedback

Regards

Hi @jjahifi, what part of the documentation is not up to date? Following the instructions in the installation guide everything should work.

Hi Alvaro, last time I installed Licode on a clean machine the installation according to the documents failed due to Node Version Manager failure. But after doing “cd licode” and running the installation script from that directory the installation worked. That was some weeks ago.

It is good if that has been corrected. I have not not checked the latest situation, I just have not been able to keep up with the fast changes in the codebase.

1 Like

Thanks @jjahifi! I think now I understand what you mean. I didn’t realized you refer to the path from where the scripts are executed. I have to check it because probably you are right. Thanks for the report!

Hi There,

I have seen that the documentation is now updated with the cd licode and with altered script paths, however I am trying to do an install on a VM machine with Ubuntu 14 Server.

Performed:
git clone https://github.com/ging/licode.git

But when running the script I get the following errors:

root@ubuntu:~/licode# ./scripts/installUbuntuDeps.sh
Checking dir /root/licode/build/libdeps/nvm
Running nvm
Found ‘/root/licode/.nvmrc’ with version <6.9.2>
v6.9.2 is already installed.
Now using node v6.9.2 (npm v3.10.9)
Found ‘/root/licode/.nvmrc’ with version <6.9.2>
Now using node v6.9.2 (npm v3.10.9)
npm ERR! Linux 4.4.0-31-generic
npm ERR! argv “/root/licode/build/libdeps/nvm/versions/node/v6.9.2/bin/node” “/root/licode/build/libdeps/nvm/versions/node/v6.9.2/bin/npm” “install” “-g” "node-gyp"
npm ERR! node v6.9.2
npm ERR! npm v3.10.9
npm ERR! file /root/.npm/node-gyp/3.5.0/package/package.json
npm ERR! code EJSONPARSE

npm ERR! Failed to parse json
npm ERR! No data, empty input at 1:1
npm ERR!
npm ERR! ^
npm ERR! File: /root/.npm/node-gyp/3.5.0/package/package.json
npm ERR! Failed to parse package.json data.
npm ERR! package.json must be actual JSON, not just JavaScript.
npm ERR!
npm ERR! This is not a bug in npm.
npm ERR! Tell the package author to fix their package.json file. JSON.parse

npm ERR! Please include the following file with any support request:
npm ERR! /root/licode/npm-debug.log
gpg: keyring /tmp/tmpd0_kgng1/secring.gpg' created gpg: keyring/tmp/tmpd0_kgng1/pubring.gpg’ created
gpg: requesting key BA9EF27F from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpd0_kgng1/trustdb.gpg: trustdb created
gpg: key BA9EF27F: public key “Launchpad Toolchain builds” imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK

Reading package lists… Done
update-alternatives: error: alternative path /usr/bin/gcc-5 doesn’t exist
No http proxy set, doing nothing
No https proxy set, doing nothing

configure: creating ./config.status
config.status: creating Makefile
config.status: creating crypto/Makefile
config.status: creating doc/Makefile
config.status: creating crypto/include/config.h
./scripts/installUbuntuDeps.sh: line 197: make: command not found
./scripts/installUbuntuDeps.sh: line 198: make: command not found
./scripts/installUbuntuDeps.sh: line 199: make: command not found

Looks like something basic is missing…
assistance is appreciated…

Regards
AB

Which flavor of Ubuntu you are using? Have you tried to reinstall Ubuntu 14.04?

I have not seen that type of errors when using plain Ubuntu.

I have downloaded the ISO from this site: http://releases.ubuntu.com/14.04/

the ISO file is ubuntu-14.04.5-server-amd64.iso

I wonder if it is supported!

Regards

I have found another ISO from the following Link which is suppoed to be 14.04.0
http://old-releases.ubuntu.com/releases/14.04.0/ubuntu-14.04-server-amd64.iso

I will try with this one and see how it goes…

Regards

That version (14.04.5) should work. I have, however, made my installations in a bit different way.

I have never installed Licode as root. I have always created a specific (non-root but with administrative privileges) user and done the installation as that user. In addition, I like to use graphical interfaces even with servers, and for that reason I have installed a desktop before installing Licode.

I would recommend you to try installation as some other user.

Hi there,

I have a fresh installation of 14.04 Ubuntu AMD 64bit server

I created another user gave admin privileges to it,

This time the ./scripts/installUbuntuDeps.sh script went little further with only few errors, however when the installErizo.sh is run I go the following errors and I needed to instal gcc manually:

zrg@ubuntu:/licode$ sudo ./scripts/installErizo.sh
Installing erizo…
– Found glib-2.0: /usr/include/glib-2.0, /usr/lib/x86_64-linux-gnu/libglib-2.0.so;/usr/lib/x86_64-linux-gnu/libgobject-2.0.so;/usr/lib/x86_64-linux-gnu/libgthread-2.0.so
– Boost version: 1.54.0
– Found the following Boost libraries:
– thread
– regex
– system
CMake Error at erizo/CMakeLists.txt:6 (message):
lib not found: NICE-NOTFOUND check README
Call Stack (most recent call first):
erizo/CMakeLists.txt:50 (test_lib)

– Configuring incomplete, errors occurred!
See also “/licode/erizo/build/CMakeFiles/CMakeOutput.log”.
zrg@ubuntu:/licode$

Something is still wrong, May be I need to have a desktop version of ubuntu…

can you send me the download link of the working ubuntu ISO

Rgrds

It may be the case that Licode has some dependencies with the desktop variety.

Because there is no real difference between the server and the desktop, please try

sudo apt-get update
sudo apt-get install ubuntu-desktop

before trying to install Licode.

It seems that there are some libraries in the desktop that make the difference.

Personally I like the Ubuntu desktop. For that reason I have always done those installation steps before proceeding with Licode.

But, honestly, I have no idea what is wrong with your situation.

Since you do not really need LibraOffice and similar things, then use the command

   sudo aptitude install --without-recommends ubuntu-desktop

for the installation of desktop related things…

Some days ago I installed Licode on a clean server installation. No problems at all. So it is unlikely to depend on desktop libraries.

@arif, have you been able to proceed with your situation?

jjahifi,

Thank you for your mail,

Kindly send the url: link of downloading the exact Ubuntu server ISO which you are using…

I will give a fresh retry …

Thanks
Regards

Arif